手当たり次第に書くんだ

飽きっぽいのは本能

WordPress ブロックエディタにしたら「更新に失敗しました。 返答が正しい JSON レスポンスではありません。」の対処

今更ですが、WordPress のエディタをブロックエディタにしようと思い、クラシックエディタを無効にしたところ、「更新に失敗しました。 返答が正しい JSON レスポンスではありません。」と表示され、公開ができませんでした。下書きは保存されていましたが。

このエラーは調べてみると、様々な要因があるようですが、私の WordPress 環境は WAF (ModSecurity) を有効にしており、それを無効化することで解消しました。

単純に無効化するとせっかくのWAFの意味がないので、部分的な対処をしてみました。内容はセキュリティに関することなので伏せます。

WordPress ブロックエディタにしたら「更新に失敗しました。 返答が正しい JSON レスポンスではありません。」の対処

コメントを残す

メールアドレスが公開されることはありません。 が付いている欄は必須項目です

日本語が含まれない投稿は無視されますのでご注意ください。(スパム対策)

トップへ戻る